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Contact Information 
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12 Lewis Street 
Camp Hill 4152 
 
P: 07 3398 4391 
F: 07 3843 3522 
M: 0414 812 905 

Email support@logchecker.com.au 
 
ABN 57 082 957 435 
 

 

 
Our Commitment 

 
·  All Enquiries will be responded to within two working days but our aim is one. 

·  A maintenance release is generally every 3 months. See  

 

The preferred method for is by email 
So you can attach screen shots about your problem. 

Attaching an export of the drivers pages speeds up the process too.  
You may need to send several emails 

as most service provider limits attachments to 2Mb 
 

Have you checked www.logchecker.com.au ? 
The information on it is much more up to date 

than this printed manual 
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What does support cover? 
 

·  Installation support : The majority of problems with installations in the past have been 
a result of restrictions placed on computers by your network administrators. Windows Vista 
facilitates even more options for control. If you are encountering issues, check our website. 
If that does not help, have your administrator contact me so that we can schedule a suitable 
time to resolve the problem together. 

 

·  Data Corruptions : None likes to lose or have to re-enter information. Make sure you 
backup regularly. The files are small and would easily fit on a memory stick.  Also, Log 
Checker contains a simple backup/restore to zip file utility. So there is no excuse for not 
having a recent backup. Our response to you will be to restore to a previous good 
backup . For those that did not backup, Log Checker also comes with a last resort repair 
facility. It may fix the problem, it may not. If it doesn’t, you will need to replace your data files 
with fresh empty ones. FAQ and Instructions for using these tools will be available on the 
website. 

 
 

·  Log Checker is wrong :  The new rules are more complex and likely to raise many 
more questions. Also each state has implemented the legislation separately and there are 
differences. The interpretation and understanding of the rules varies with each person and 
enforcement officer. But if you do feel it is wrong, please export and email the drivers pages 
along with why you think it is wrong.  

 

·  Program updates from the Web :  While you have a valid maintenance license you 
will be able to receive updates from web. See Updates If there are any critical updates will 
also inform you via email.  A CD with the latest update will also be sent to you when you 
renew your maintenance. 

 

Maintenance Fee 
 

The program comes with up to a years maintenance included in the original purchase. A 
nominal maintenance fee will be levied in September each year. A reduction will be applied 
to the fee, If you have purchased the program within the previous 6 mounts, 
 
This will be used to drive improvements as well as funding the next major rule change. 
 

Suggestions 
We also welcome suggestions from users. See Updates 
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Activation Key 
The installation CD does not contain any activation keys. After installing the program it will run in trial mode unless you 
enter the activation key.  
 
In Trial mode you can run the program for up to 2 hours, 25 times. All information entered is retained when you activate 
the program.  
 
Activation keys are only provided on payment. So it is important that you expedite the payment process so that you can 
fully use the program without delay. 
 
To enter your activation key see Activating the program 
 

Trial version 
We no longer offer a trial version as most of those that asked for one, often did not have enough time to try it before the 
trial ran out. Instead, we offer a 30 day refund if you decide not to use it. Just return the CD and activation key. 
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Updates 
Log Checker has a built in update from the internet facility. But you can also apply updates 
manually. Information about updates can be found at 
http://www.logchecker.com.au/next_update.htm 
 

 
 

 
  

Normal Update procedure 

�  Ensure no one else is using Log Checker 
�  Backup your program files (Default location is C:\Program files\Logchecker4) 
�  Backup the Log Checker data files (Default location is C:\LogcheckerData) 
�  Start Log Checker 
�  Chose help -> check for updates from the main window 

 
�  If you do not have an active connection to the internet or your network security is preventing 

access, a window will popup after a few moments describing the problem. Have your IT 
people check it and apply the update manually. 

�  If an update is available a popup window will display information about the update and 
whether you want to apply the update. Make sure you read this information as it may 
contain specific instructions about the upgrade. Click Yes to download and apply it. Click 
later to cancel the update. 

�  After clicking YES, a download window will display. Once it has downloaded the program it 
will replace the LC4.exe program file and restart the Log Checker. 

���������	���
	�����	�
��
��
���� 	

Make sure you have Administrator access when performing upgrades. 
If you are using Vista, make sure you run the program as an administrator 
If you are using Terminal Server make sure you place the terminal server into 
install mode before running the upgrade and execute mode after the upgrade. 

 

�
���
	�����
��	��	�����
�	
Make sure you backup the Log Checker Program directory. 
Make sure you backup your data files as an update often involves changes to the 
database. 
Doing so will ensure that you can resume normal operations quickly in the event of 
a problem. 
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�  If the upgrade includes database changes, a database upgrade window will popup to check 
that you have made a backup. If you haven’t cancel the upgrade, make a backup and then 
start Log Checker again. The Database changes may take a while depending on how much 
data you have. Be patient. Once they are complete, the Log Checker main window will be 
displayed. 

�  Repeat the process on each computer, If you have Log Checker installed on more than 
one. 

 
Manual Update 

Instructions for obtaining the update and applying it manually can be found on 
http://www.logchecker.com.au/manual_update.htm 
 

�  Ensure no one else is using Log Checker 
�  Backup your program files (Default location is C:\Program files\Logchecker4) 
�  Backup the Log Checker data files (Default location is C:\LogcheckerData) 
�  Download the update file and save it to a temporary location on your computer.  
�  copy the updated file from your  temporary location program to the 'C:\Program 

Files\LogChecker4' directory  
�  Rename the existing LC4.exe  to LC4.old  
�  rename the updated file to LC4.exe  
�  Now start Log Checker normally 
�  If the upgrade includes database changes, a database upgrade window will popup to check 

that you have made a backup. If you haven’t cancel the upgrade, make a backup and then 
start Log Checker again. The Database changes may take a while depending on how much 
data you have. Be patient. Once they are complete, the Log Checker main window will be 
displayed. 

�  Repeat the process on each computer, If you have Log Checker installed on more than 
one. 
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Information for support 

To assist us in diagnosing issues, Log Checker displays a number of settings in the about box.  
When you contact Support please include this information 
 
To include the about box information in an email 

�  Chose Help-> About from the Main window. 

 
�  If you are using a dedicated email program like Outlook, click on email. It will open your 

email program and create a new email with the information. Now add your comments and 
press send. 

�  If you are using a web based email program like Hotmail, open your email, create a new 
email. Press copy from the Log Checker about box to copy the information to the clipboard. 
Paste (ctrl V) the information into the email, add comments and send it. 
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What is Log Checker and what will it do? 
 
Log Checker is a relatively inexpensive program that is designed to help you manage your 
drivers driving hours. Used regularly and correctly, it can help you avoid costly penalties. The 
main features of the program are 

·  Check drivers pages for breaches 
·  Plan trips to avoid breaches 
·  Assist you to meet accreditation requirements 

 
How does LogChecker Work? 
 
Log Checker presents the pages like existing log books. 
 
Just drag the mouse across the time blocks just as you would do with a pen. As soon as you 
close the window, Log Checker recalculates the breaches for that day (and later days in the 7 
day window). But it does not just recalculate that particular day. It scans backwards and 
forwards through the drivers pages and recalculates the rules for all periods. Then it indicates 
the breaches. 
 
You can enter and edit pages one day (1) or fourteen (14) days at a time. The single day (1) 
entry allows you to record more information like the page no, add comments and provides more 
information about breach details. The fourteen (14) day page allows you to see the pattern of 
driving which is helpful for the longer rest breaks and limits. 
 
But one of the best features of Log Checker is that you can quickly alter a trip by moving the 
blocks of time around with the mouse. Does a longer break here fix the problem? Or what if we 
start earlier or later? Instantly, Log Checker recalculates and shows the results. Now you can 
give the driver the feedback that he needs in order not to repeat the breach. 
 
When should you use Log Checker? 
Log Checker is a tool to be used to meet your legal and accreditation requirements. It will save 
you lots of time and help you avoid penalties. You should be using it 
 
Daily 

�  to capture log pages from drivers 
�  to plan trips before sending drivers out 

Weekly 
�  to check pages for breaches 
�  to gather information about actions to support your accreditation 
�  to raise corrective actions 
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Supported Schemes 
 

 
Generally, Log Checker applies the lowest common denominator principle. 
Log Checker may indicate a breach that may not actually apply because of the particular States 
variation. It is unlikely to miss a possible breach. 
 

 
Ö Standard (effective 29 Sep 2008) 
Ö Standard Two Up(effective 29 Sep 2008) 
Ö BFM (effective 29 Sep 2008) 
Ö BFM Two Up (effective 29 Sep 2008) 
Ö Solo Bus (effective 29 Sep 2008) 
Ö Standard (pre 29 Sep 2008) 
Ö TFMS (pre 29 Sep 2008) 
Ö WA 
Ö WA Two up 

 
X Advanced Fatigue Management (AFM) is not supported as rules are specific to
 each organization. It may be possible to develop a customized version for you. 
 

Daylight Savings Time and other Time zones 

The legal entry requirements for the Driver's Log book state that all time entries must be entered 
using the time of the departure point for the entire trip and that all entries on a page be made 
according to the same time zone. 
Currently, Log Checker makes all its calculations based on time entries being made in the same 
time zone and does not allow for pages being in different time zones. Therefore, we suggest 
that you use the time zone of your main depot for all time entries. 

Each state implements its own laws. 
Even though they all agreed to support the National legislation, there are differences! 
Log Checker uses the rules as specified in the NTC model legislation. 
 

In the past, the interpretation of some rules changed after they were implemented.  This may 
happen with the new rules after Sep 29 2008.  
We will be monitoring the situation. 
But let us know if something changes so that we can update the program  
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Log Checker Main Window 
 
This is the main Log Checker window. From here you can enter data by clicking on the edit 
single or 7/14 day buttons or choose other functions from the window menu. 

 
 
First Steps 
Before you start entering pages, you need to set up divisions, drivers and enter your BFM 
number if you have one. 

Divisions 

Divisions in Log Checker are simply a way of grouping your drivers for operational purposes. If 
you have multiple depots that manage different drivers then you should set up the divisions. 
This will allow each user in the division to enter data and report on only their active drivers. Even 
If you only operate out of one division you still need to set up one.  
 
Log Checker has two special divisions. The division ALL will show all drivers including the 
inactive drivers. The Inactive Drivers division is used to retain information for the drivers who no 
longer work for you.  
 

 
 

 

Hint: 
When a driver leaves, rather than deleting drivers, set them to Inactive. 
This way you will keep their history and they won’t appear in the driver lists. 
If they come back, just change the drivers division back to the active one 

Note: 
Note that no security or restrictions are applied to users. 
A user can select any other division / driver at any time 
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Chose File-> Edit -> Divisions from the Log Checker Main window 

 
To enter a new division 

·  right click in the bottom section of the Divisions Screen 
·  select New Division, A new row will open. 
·  Type the name of the division then press Enter to save the information 

 

 
To rename a division 

·  Double click on the division name 
·  Type the new Name 
·  then press Enter to save the information  

 
To delete a division 

·  Right Click on the division name 
·  Choose delete 

 

������	�������������
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LogChecker allows each user to select a default division which it will remember and use when 
selecting drivers each time you use the program. 
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To select a default division 
·  Open the edit Division Window 
·  Then click on the current Division list box and choose the division you want 
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Drivers 
 
The drivers window allows you to record and manage information about your drivers.  
 

 
 
The Driver Name must be unique across all divisions 
 
License details should be entered as the license number is recorded on each page that is 
created. You should enter the license renewal date and take advantage of the renewals report. 
 
Most accreditation schemes require that your drivers undergo regular medicals. You should 
enter the license renewal date and take advantage of the renewals report. 
 
Log Checker allows you to have drivers operating under different rules. To avoid mistakes, you 
can preset the rule to use for each driver by setting the WA, Two Up, TFMS, Bus and BFM 
flags. You can always override the program and select a different rule for a page, but setting the 
information here will ensure that the appropriate rule is used for each driver. The TFMS rule 
only applies to pages prior to 29 Sep 2009. For current rule selections use the following table: 
 

Default Rule W
A 

Two 
UP 

BUS BFM 

Standard     
Standard Two 
Up 

 X   

BFM    X 
BFM Two Up  X  X 
Solo Bus   X  
WA X    
WA Two Up X X   

 
The Division allows you to choose which list the driver will appear in. It can easily be changed at 
any time. You should avoid using the ALL or Inactive Drivers divisions for active drivers. 
 
Started and Left dates can also be entered. If left blank the program will set it to the current date 
if you add a driver or set a driver Inactive. 
 

 

Hint: 
Log Checker uses the license and rule flag information as defaults when creating pages, so 
please keep it up to date. Especially, the license details and the rule flags. 
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Deleting a driver will remove them from the system permanently. If you add them back later, 
pages previously entered for that driver will not be available. Corrective Action Request 
information will also not be available. To retain the drivers information, Log Pages and 
Corrective Action Requests set them to the Inactive group. If they rejoin you, you will still have 
their page history. 
 

 
 

�������
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Chose File-> Edit -> Drivers from the Log Checker Main window 

 
 
A right mouse click will popup a menu of actions for you to choose from. 

 
 
To enter a new driver 

·  choose Edit-> New Driver from the windows menu or right click on the driver details  
·  A new row will open. 
·  Fill in as much detail as you can, assign them to a division 
·  then press Enter until you are on another row to save the information 

Hint: 
Check with your accreditation provider as to how long and in what form you should keep log 
page and Corrective Action Request information before deleting drivers. 
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To change a driver’s details 
·  Double click on the drivers name 
·  Change the details as needed 
·  then press Enter until you are on another row to save the information  

 
Setting a driver Inactive 

·  click on the drivers name 
·  right click and choose Set Driver Inactive from the popup menu. The driver will be 

removed from the current division and be added to the Inactive Drivers division. The Left 
date will also be updated if it has not been previously set. 

 
Reactivating a driver 

·  Choose the inactive drivers division 
·  click on the drivers name 
·  change the division name to an active one 
·  then press Enter until you are on another row to save the information. The driver will no 

appear in the chosen division and the date left will be cleared. The original joining date 
remains unchanged. 

 
Permanently delete a driver 

·  click on the drivers name 
·  right click and choose Delete Driver from the popup menu. The driver will be removed 

from the system and you will no longer have access to any of his Log Pages or 
Corrective Action requests 

 



�   Page 18  June 29, 2009 

 

BFM Details 

 
If you are operating under BFM, Log Pages are required to have the BFM accreditation number 
entered on each page. To save you the effort of entering the information each time, you can 
enter the information in this window and the program will use it as a default. You can override 
the number on any Log Page at any time. 

�����������������
Chose File-> Edit -> Drivers from the Log Checker Main window 

 
Enter the BFM number, date information and then press Exit 
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Entering Pages 
Log Checker uses a Time grid to enter / display the driver activities. It looks and acts very much 
like the paper log page. Just drag the mouse across the page as if you were drawing a line with 
a pencil. Both the Single Page entry and the 7/14 Day page entry have time grids and allow you 
to enter / edit the Log Pages. The difference is that more information is displayed and can be 
edited in the Single Page window. 
 

 
 
Both the Single Page entry and the 7/14 Day page entry allow you to enter activities in full or 
quick format. In full format after entering an activity, a popup window is displayed that asks for 
Location, Vehicle and Odometer details. In quick format, it will not ask you. 
 

 
 

1 Single Page - Full Entry mode 

 
2 Single Page - Quick Entry mode 

 

Hint: 
If you have ready access to the Location, Vehicle and Odometer details in another system 
or from the original pages, consider using the Quick entry mode. 
 

Hint: 
Use the single page entry to capture the actual log pages and record Corrective Action 
information. Use the 7/14 page entry to look / resolve breaches for longer periods. 
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3 7/14 day - Full entry mode 

 
4 7/14 Day - Quick entry mode 

 



�   Page 21  June 29, 2009 

 

Using the Time Grid 

The time grid is used to enter and display the driver’s activities. It consists of activity rows (work, 
non work etc) that are divided into time blocks according the scheme you are using. In full 
format, the grid will also display location, vehicle and odometer rows. Breaches are displayed as 
an X in the time block. 
The left mouse button is used to enter and move activities. Before you can enter activities you 
must load a page or plan. 
The right mouse button is used to load pages / plans, change rules, change layout and display 
information about that activity block. 

 
 

������������	��
�  Right click anywhere in the time grid (but not on the row headings) 
�  Choose Pages 
�  Choose Load 

 

 
�  The division will default to the current division, but you can override it by selecting another 

division from the drop down list. 
�  Select the driver from the drop down list. Note that the driver list only displays those 

belonging to the selected division. 
�  There are two date selection boxes. The left one displays pages that have already been 

entered in descending order. The right hand one allows you to enter a date or choose a date 
from the popup calendar. You can use either method. If a page exists it will be loaded. If it 
does not exist it will be created. 

�  Click on OK 
5 Time Grid display after creating a new page 

 
6 Time Grid display after loading an existing page with a breach 

 

Note: 
All changes are automatically saved and all activities on that page are rechecked 
against the rules on every change! 
 

Hint: 
You can do a lot more from this menu. Have a look at the other menu options later 
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Hint: 
If you want to correct or delete any rego numbers 
choose Edit-> Vehicles from the Main window menu. 
 

��������������
����� 
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Before you can enter activities you must load a page or plan. 
�  Position the mouse over the starting time block in the activity row eg Work 
�  press  and hold  the left mouse  button down 
�  Now drag the mouse to the end time block and release the button 
�  If you are using Full entry mode, a window will popup 

7 Popup Activity Windows, (work and driving activities will ask for more details than rest) 

 
·  In the From / To list box start typing the first few characters of the place name. The 

program will try to match the name from its known list of places. (Log Checker comes 
with all postcode locations). You can also select the place from the drop down list. To 
add a new place just type its full name and press enter. A window will then popup asking 
you what state it is in before adding it to the list. 

 
In the Rego list box start typing the first few characters of the rego. The program will try to match 
the name from its known list of places. To add a new rego just type it in full and press enter. 
 
In the Odometer box you can type the new reading or use the up / down spin arrows. 

Once all the information is entered. Click on OK. Log Checker will save the information and 
update the time grid display. 
 

���
����
�������
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If you accidently make an activity too long, just click or drag on the correct activity to fix it. Eg 
Work activity was entered from 2.00 to 4.15 when it should have been 4.00 
Just click in the rest activity for 4.00 
If it was a bigger mistake,  

�  Position the mouse over the rest period for the previous or ending time block 
�  press  and hold  the left mouse  button down 
�  Now drag the mouse to the correct time 

Hint: 
If you want to correct or delete any places 
choose Edit-> Places from the Main window menu. 
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�  Position the mouse over the activity you wish to move 
�  Hold down the shift key , then press  and hold  the left mouse  button down 
�  As you drag the mouse left or right, the activity will also move. 

 
���"������������������������$��

�  Position the mouse over the activity you wish to start moving from 
�  Hold down the Ctrl key, then press and hold the left mouse button down 
�  As you drag the mouse left or right, the activity and all those behind it will also move in the 

direction of the mouse. 
 
������$���"������%&����&'�������"���

�  Right click in the time grid 
�  Choose Layout 
�  Tick or untick show time in 12 hr format. 

 
������$���������
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�  Right click in the time grid 
�  Choose Layout 
�  Choose Landscape or Portrait 

 
������$�����
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In the single page window you can also view the breach information in the Analysis tab at the bottom 
�  Position the mouse above the time block with the breach. 
�  Right click 
�  Choose Breaches this block 
�  Each Breach is displayed in the menu 

 
������$���"�������

�  Position the mouse above the time block that you want to see the information for. 
�  Right click 
�  Choose Time Used 
�  The time used information for each period is displayed in the menu 

 
������$���"�������

�  Position the mouse above the time block that you want to see the information for. 
�  Right click 
�  Choose Time Left 
�  The time left information for each period is displayed in the menu 
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Edit Single Page 

The single page window is the main work horse of Log Checker. In here you will 
·  enter the page information from the drivers log book page 
·  investigate the breaches 
·  update information to show your actions for accreditation 
·  update information to create Corrective Action Requests 

 
 
The top section of the window contains the log page information that should be captured from 
the drivers paper log page. The middle section is the time grid. The bottom 2 sections are for 
accreditation, corrective actions and breach detail. 
 
������
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The date is for display only. But you can use the left and right arrows to go to the previous / next 
page. 
The page number should be entered so that you can be sure of having all 
of the driver’s information by running the missing pages report. See 
Missing and Cancelled Pages 
The time zone as recorder by the driver. See Daylight Savings Time and 
other Time zones 
The rule that is being used will be displayed here. Log Checker will 
automatically select the rule to use based on the drivers settings. But you 
can change it by selecting from the list or by right clicking in the time grid, 
choosing rules and then selecting the rule. See Edit / create Drivers 
Driver License and Issuing State details are automatically filled with the 
driver’s current information when a page is created. To update them with the driver’s latest 
information click on the button to the right of the state field. 
BFM number will also default to the system default when a page is created. See BFM Details 
But you can also override the value by typing a new one. 
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You can switch the time grid between quick and full modes any time by clicking on the menu at 
the top of the window. For more information about loading pages and entering activities see 
Using the Time Grid 
 
 

����������������"������������	���)�	��

This section is used for recording your actions for accreditation summary purposes. The 
information is summarized and reported in the Accreditation Summary report. 
Tick the Checked box when you have reviewed the analysis / breach information 
Tick the Driver Informed box after you have spoken to the driver about a breach 
If you are using Corrective Action Requests or Non Conformance Reports, enter the number 
here after it has been raised. 
 
���������"���
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The bottom section has three tabs that allow you to view breach details and optionally enter 
information for the Corrective Action Reports. 
 
��������!������������������	�����	��

 
This tab displays all the breaches for the current page, the rule used and end of day totals. If 
there are no breaches it will display OK 
 



�   Page 26  June 29, 2009 

 

��������
�������������������	�����	��

 
This tab displays in detail how Log Checker has added the times and arrived at a breach. To 
use it just select the breach from the List. 
 

 
 

(��!�����������	�
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Log Checker’s interpretation of the rules is based on the legislation and advice from authorities.  
If you feel that Log Checker’s calculations are wrong, export the drivers pages (see Export Log 
Pages) and email them, the Information for support, and why you think it is wrong to 
support@logchecker.com.au We will then load the exported pages and check the calculations. 
Checking the details is quite time consuming, so please do use this facility just to vent some 
anger about a particular rule. 

Hint: 
Most disagreements about interpretation of the rules relate to when they are 
actually counted from. Check the start and end periods displayed in this screen 
first. 
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Edit 14 Days of Pages 

This window displays only the time grid for 7 or 14 days in either full entry or quick entry mode. 
Each day is separated by a blue line. You can enter and edit the activities just like the single 
page. See Using the Time Grid. Breaches are displayed as an X. To view them see To view 
breach Information. In addition to displaying drivers log pages, you can also create plans and 
compare plans and actual log pages. See Plans. 
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Fixing Page Mistakes 
Log Checker has a number of features for fixing page entry 
mistakes. These features are accessed via the edit Menu from 
the main Log Checker window. 
 
 

Delete a page 

Deleting a page will remove it permanently from the system. You will be able to enter a new 
page for that date if you need to. 
�  From the Log Checker Main window menu choose 

Edit -> Delete Entire page. 
�  Select the driver from the list 
�  Select the page from the list 
�  Press Delete 

 
 

Change the date for a page 

Deleting a page will remove it permanently from the system. You will be able to enter a new 
page for that date if you need to. 
�  From the Log Checker Main window menu choose 

Edit -> Change the driver for entered page. 
�  Select the driver from the list 
�  Select the page from the list 
�  Enter the new date 
�  Press Apply 

 
Change the driver for a page 

Deleting a page will remove it permanently from the system. You will be able to enter a new 
page for that date if you need to. 
�  From the Log Checker Main window menu choose 

Edit -> Change the driver for entered page 
�  Select the driver from the list 
�  Select the page from the list 
�  Select the new driver from the list 
�  Press Apply 

 

Canceling a page 

This will be added in a future update. 
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Plans 
 
Knowing that you can safely send a particular driver on a trip is becoming increasingly 
important. Log Checker can help you to avoid penalties and hopefully accidents by creating and 
checking a trip plan before sending a driver out. 
 

 
 
Plans can be from 1 to 14 days. They are created and edited in the 14 day view just like log 
pages. The main difference is that you right click and choose Plans->Load instead of Pages 
Load. Plans are also displayed in slightly different colors to distinguish them from pages. 
 
Log Checker has two types of plans. Both are reusable. 

·  Generic plans contain no driver history and are checked against the rules assuming that 
the driver has all driving periods available. Generic plans have no start date and are 
displayed as day numbers. 

 
·  Driver plans are checked using the drivers entered pages (prior to plan date). This 

enables you to tailor a plan to ensure breaches are avoided. Driver plans have a start 
date and are displayed as dates.  

 

 Advice: 
Many operators tell me that they don’t know what they are doing until the customer tells 
them how big the load is and when it will be ready. So how can they plan?  
They are bound by the Chain of Responsibility and so are you. Knowingly, dispatching a 
driver on a trip which is clearly in breach of regulations can result in you, the client and the 
directors / owners of both companies facing severe penalties and possible jail terms. 
So protect yourself. Apply the prepared plan to the driver for the desired pick up / delivery 
times. Adjust the plan to make it within regulations. 
Call the customer and advise them of the revised or expected delivery time. Make a record 
of the conversation (Chain of Responsibility) and the outcome. Especially, if they demand 
it earlier. 
Give the driver a print out of the revised plan so that he is aware of your expectations. 
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Recommended Usage 

Create Generic plans for all your normal trips assuming that the driver has full availability. If a 
trip is quite lengthy, consider making some smaller sub plans so that they can quickly be applied 
to other drivers if you need too. 
 
Copy / Apply the plans to a driver. Then tailor the drivers plan to avoid breaches. 
 
After the driver completes the trip, Compare the drivers plan to the actual Log Pages. Revise 
the plans if needed. 
 

Create / Edit Generic Plan 

�  Choose Plans 
�  Choose Edit / Create Generic Plan 

 
 
�  Accept the division or choose another from the list 
�  To use an existing plan select it from the list and click Open 
�  To create a new plan, enter the plan name, the rule to use and click new. 

 
 

 
�  Edit the plan just like a log page. Breaches are displayed as an X (see Using the Time Grid)  
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Copy / Apply Plan 

Plans are applied to a driver by copying them for a specific date and time. By copying them, you 
can make changes for that driver without affecting the original plan. The copy / apply plan can 
also be used to create new generic plans as well. 
 
�  Choose Plans 
�  Choose Edit / Create Generic Plan (this is the original) 
�  Choose Copy / Apply Plan (this will be the copied plan) 

 
�  Accept the division or choose another from the list 
�  Tick Generic plan or choose the driver from the list for a driver specific plan 
�  Enter the new plan name (pan names must be unique) 
�  If it is a driver plan enter the Start date 
�  Accept or rule or select another from the list 
�  Use the adjust by Hours and mins to change the starting time for the plan. For example if the 

plan started at 6am but we wanted the copied plan to start at 4am, Change the adjust by to -
2 hours. Plans can be adjusted by up or down by 23 hours 45 mins 

�  Click on ok 
�  The new plan will be created and then loaded for further refinements 

 

 

Hint: 
You can reapply a drivers plan by changing the start date or by copying it. 
If you copy it, you will be able to compare the actual pages with the plan. 
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Create / Edit Driver Plan 

�  Choose Plans 
�  Choose Edit / Create Driver Plan 

 
 
�  Accept the division or choose another from the list 
�  Select the driver from the list. 
�  Only the plans for that driver will be shown. 
�  To open an existing plan. 

�  Click on the plan name 
�  You may prefer to change the Start date here rather than creating a copy of it for another 

date. But you will not be able to adjust the start time. 
�  You can also change the rule used to evaluate the plan if needed. 
�  Click on Open 

�  To create a new driver pal. 
�  Right Click on any plan name 
�  Choose add a driver plan 
�  Enter the new plan name 
�  Enter the new start date 
�  Choose the rule to use 
�  Click on Open 

�  To delete an existing plan. 
�  Right Click on the plan name 
�  Choose delete this plan. 
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Compare a Plan 

Plans can be compared with actual pages. Differences are highlighted as blue * 
 
�  Right click and Load the drivers log pages (pages-> Load) 
�  Right click and Load the plan (Plans-> Edit / Create …) 
�  Right click and choose Show -> Compare plan and pages 

 
�  Note the differences highlighted by blue * 
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Printing Plans 

�  From the Log Checker Main window choose Reports  > Plans 

 
�  Accept the default division or choose another from the list 
�  Select a generic plan from the list 

or Select a date range for driver plan start dates 
or select a driver from the list and then a driver plan from the list 

�  Check or uncheck the new page per driver 
�  Check or unckeck Landscape format 
�  Check or uncheck Include Analysis 
�  Print will send the report to the default windows printer 
�  Preview will display the report the screen. In the preview screen you can send the report to 

the default or a different printer 
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Reports 
 

Printing Pages 

This will print all selected pages  
�  From the Log Checker Main window choose Reports  > Pages 

 
�  Accept the default division or choose another from the list 
�  Select All drivers or a driver from the list 
�  Select a date range 
�  Check or uncheck the new page per driver 
�  Check or unckeck Landscape format 
�  Check or uncheck Include Analysis 
�  Check or uncheck Include Corrective Action comments 
�  Print will send the report to the default windows printer 
�  Preview will display the report the screen. In the preview screen you can send the report to 

the default or a different printer 
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Driver Status 

The driver status report shows the current availability of your drivers based on the information 
that has been entered. If you are keeping the log pages up to date, you can use this report as a 
quick finder for when someone rings in sick. 
 
If there are gaps between the information entered and reporting date, the report will display a **  
in the Possibly Missing Log Pages column. It is intended as a quick guide only. You should 
always plan and check a driver’s trip before they go out.  
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�  From the Log Checker Main window choose Reports  > Driver Status 

 
�  Accept the default division or choose another from the list 
�  Select the date that you want information for 
�  Print will send the report to the default windows printer 
�  Preview will display the report the screen. In the preview screen you can send the report to 

the default or a different printer 

Important Note: 
Only use this report if the log pages entered are u p to date. 
Recheck the trip plan before sending the driver out  
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Breaches 

The breaches report will print log pages that have breaches with analysis information for the 
selected range of drivers and dates. 
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�  From the Log Checker Main window choose Reports  > Breaches Report 

 
�  Accept the default division or choose another from the list 
�  Choose all drivers or Choose a driver from the list 
�  Select the date range for the report 
�  Tick or clear the New page per driver (recommendation is tick) 
�  Tick or clear the Landscape format option (recommendation is tick) 
�  Tick or clear Include Corrective actions (recommendation is clear) 
�  Print will send the report to the default windows printer 
�  Preview will display the report the screen. In the preview screen you can send the report to 

the default or a different printer 
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Operations 

The Operations report will print log pages that have breaches with analysis information for the 
selected range of drivers and dates. 
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�  From the Log Checker Main window choose Reports  > Breaches Report 

 
�  Accept the default division or choose another from the list 
�  Select the date range for the report 
�  If the Include Log Page dates is ticked, information from each log page will be printed. 

Otherwise only a summary for the driver is printed. (recommendation is tick) 
�  Print will send the report to the default windows printer 
�  Preview will display the report the screen. In the preview screen you can send the report to 

the default or a different printer 
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Missing Pages 

The Missing Pages report will show 
·  Pages entered that have no page number 
·  Breaks in a sequence 
·  Pages out of sequence 

 
������������������

�  From the Log Checker Main window choose Reports 
�  Choose Accreditation Summary 

 
�  The division will default to the current division, but you can override it by selecting another 

division from the drop down list. 
�  Select the date range by entering the dates or using the popup calendars 
�  Print will send the report to the default windows printer 
�  Preview will display the report the screen. In the preview screen you can send the report to 

the default or a different printer. 
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Accreditation Summary 

The accreditation summary provides a total and for each driver of 
·  The pages entered 
·  The pages checked 
·  The pages discussed with the driver 
·  Breach counts 

This information reported here is entered on the Accreditation information of Single Page 
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�  From the Log Checker Main window choose Reports 
�  Choose Accreditation Summary 

 
�  The division will default to the current division, but you can override it by selecting another 

division from the drop down list. 
�  Select the date range by entering the dates or using the popup calendars 
�  Print will send the report to the default windows printer 
�  Preview will display the report the screen. In the preview screen you can send the report to 

the default or a different printer. 
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Corrective Actions 

The corrective action report will print the corrective action Requests from information that has 
been entered (see Accreditation information of Single Page). The report can be produced for 
any selection of 

·  Breach 
·  CAR Number has been entered 
·  Problem description has been entered 

 
The report displays 

·  The time grid activity rows 
·  The Problem description 
·  The Short term action 
·  The long term action 
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To run the Corrective report 
·  Choose Reports -> Corrective Actions from the main window 

 
·  Accept the current division or override it and choose another division from the list 
·  Tick All or select a driver from the list 
·  Select the date range for the report. Click on the calendar icon to select the date from a 

calendar 
·  The Print if… triggers control whether a page is printed or not. By default a page is 

printed if any of the following have occurred 
o Log Page has a breach 
o Car Number has been entered 
o Problem description has been entered 

You can change the behavior by checking or clearing the Print if … options 
·  Print will send the report to the default windows printer 
·  Preview will display the report the screen. In the preview screen you can send the report 

to the default or a different printer. 
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License  / Medical Renewals 

These reports display the renewals due in the reporting period. 
 

 
 

 
 
To run the Reports 

·  Choose Reports -> License Renewals Due 
Or  Reports -> Medical Renewals Due from the main window 

·  Accept the default division or Choose another Division from the list 
·  Choose the Due By Date 
·  Tick or clear the include blank dates. Include them is recommended to ensure you 

capture the dates from drivers who have not provided the information to date. 
·  The screen will now update and display the renewals due 
·  Click on Print to print it 

Have your say: 
One of the enhancements on the drawing board is to add renewals for permits and 
vehicle / trailer registrations. All these renewals would be reported in a single 
report.  
Are there other renewals we can add? 
Should they be in one report or separate reports? 
It may be possible to update Microsoft Outlook with a reminder calendar. Would 
that be usefull? 
 



�   Page 44  June 29, 2009 

 

Exporting and Importing Pages  
 
The import and export facility is used 

·  for sharing data between separate Log Checker systems when you have none or a slow 
network. eg Cairns and Head office. 

·  For sending information to support 
 
The file used by the utilities is in text based CSV format but contains a number of different 
record types. 
 

  
 

Export Log Pages 

�  Choose File -> Export Drivers & Times for another Log Checker Program from the main 
window 

 
 
�  Select the driver or all drivers 
�  Select all dates or a date range. If you are 

sending these to Log Checker support, 
please use all pages. 

�  The program will create a default file name 
and directory. You can change them if you 
wish. 

�  Click on export 
�  A window will popup displaying the number of entries created in the file. Make a note of the 

full path of the file, so that you can transfer it later. 

  

Note: 
The format is not intended for data import from other programs. If you have a need 
for this please contact support to discuss the options available. 
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Import Log Pages 

The import program is a separate program. 
�  Close all Log Checker programs to avoid locking issues. 
�  From Windows choose Start-> All Programs -> LogChecker4 -> Import Utility 

 
�  Select the file to import the data from. You can use the browse button to locate it. 
�  If Replace Existing pages is checked, any existing pages will be replaced with the times and 

information from the data in the file. Replace Existing pages should usually be checked. 
�  Press Import 
�  When the import is complete, a window will display the number of records updated 

 
 
�  Close the import program 
�  Start Log Checker to view the imported pages. 
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User Licensing 

 
Log checker is sold on a per user license. A user is a computers that Log Checker is installed / 
operated from. It does not matter how many drivers or people use Log Checker. You are required 
to have a license for each computer you install / operate Log Checker on. 
 
There is no restriction on the number of pages or drivers you can enter other than the physical 
limitations of your computer and the software. 
 
The standard version allows for installation on 2 computers plus occasional use on a Laptop for 
when you visit a remote depot. The idea is that both office computers are networked. One is used 
by office staff to enter the driver’s pages. The other is used when scheduling or checking pages. 
 
If you are using Terminal Services to host the application for multiple users, then you must 
purchase enough user licenses to cover your normal number of users. 
 
Log Checker has the ability to track how many people are using it. Currently, we are relying on 
your honesty, and giving you some leeway. Please don’t abuse it. 
 

Supported Operating Systems 
 
Log Checker has been tested on Windows XP and Vista. 
Log Checker may work on Windows 2003 server but we currently do not support that platform 
Log Checker 4 may work on older windows operating systems but we currently do not support them. 
 

Computer Requirements 
 
Most Vista compatible computers purchased with the last 18 months or so will run Log Checker nicely. 
Systems older than that are likely to encounter performance issues that may make using the program 
difficult. 
 
Screen size is important. The 14 Day view uses lots of screen real estate. It is recommended that you 
consider a 21” monitor or dual monitors in order to avoid having to continuously scroll the window to see the 
details. 
 
Log Checker uses the Borland Paradox database as its repository. There are only a handful of files and they 
do not take up a lot of space by today’s standards. But the activity is quite heavy and they should not be 
located on a slow server. 

 
 

 
Make sure the files are backed up Weekly. 

We can no longer offer any data repair services. 
Log Checker Backup will create a zipped archive of the data files. 
But you should also transfer it CD or another computer for safety. 
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Installation Overview and Requirements  
 

Installation and registration is a 3 step process 
 

1. Install Log Checker 
2. Reboot the computer  (absolute must do otherwise program may not work!) 
3. Run LogChecker and Activate it with the Key details you have been given 

 
 
Program file Locations 

 
The data files and programs are located in separate directories. They are 
 
 Programs :   program files\LogChecker4 
 Data Files :   c:\LogCheckerData 
 Data Backups :  c:\LogChecker\backup 
 
The installation only prompts for the data files location. It is recommended that you accept the default 
location of c:\LogCheckerData 
 
 
Registry Locations 

 
 Hkey_Local_machine\Software\LogChecker4 
 Hkey_Local_machine\Software\LC4 
 Hkey_Local_machine\Software\XLC4 
 Hkey_Current_User\Software\LC4 
 
 
Administrator Requirements 

The setup program will need administrative rights in order to install and activate Log Checker 
 
The following programs require administrative rights 
 
 program files\LogChecker4\LC4.exe 
  main Log Checker program, updates itself and adjusts db configuration when needed 
 C:\Program Files\Borland\Common Files\BDE\BDECFG.EXE 
 Borland database configuration utility 
 Program files\LogChecker4\Logchecker_Repair.exe 
  Utility to reindex, rebuild the paradox files. 
 Program files\LogChecker4\ LogCheckerImport.exe 
  Utility to import data from other Log Checker Programs 
 
Vista  manifest files have been included for these files 
 
Terminal services  must be put into install mode and returned to execute mode during installs and 
upgrades. 
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Paradox networking file 

 
The Paradox database uses a file named PDOXUSRS.NET to control locking. Originally this file was 
automatically created in the root directory of the C drive. Vista now restricts this, so the file is now created 
during the installation in the c:\LogCheckerData directory and Log Checker updates the Borland Database 
Engine to use this new location. 
 
When networking computers, this file and the log checker data files need to be accessed by the same drive 
/ path name. 
 
Installation 

 
The install should automatically start after the cd is inserted. If it does not, run the setup program located in 
the logchecker directory. 
 

 
 
Activating the program 

The activation can be entered at the splash screen or from a menu in the Log Checker Program. 

 
 
The Activation details supplied contain a serial no and a Activation Key. All 0 or 1’s in the serial number are 
the digits. It does not contain any O or I letters. 

 
If you have misplaced your key, you can check the details of a registered version by going to the Help-> 
about menu. 
 
 

You must reboot the computer after the installation 
as the Borland Database Engine needs to perform some updates 

 at startup to complete its install. 
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Before you start  

 
Read the Installation Overview and Requirements 
 
The install program on the CD is designed for a local install. To install a networked version the process is 

�  Install log Checker locally on each PC 
�  Install Log Checker on the server 
�  Reconfigure the BDE engine on the server  to facilitate sharing. 
�  Reconfigure the BDE engine on each PC to use the networked data files and sharing. 

The information following describes the process in more detail. 
 
A peer to peer network does not use a dedicated server to host the data files. Instead one of the user’s computers is 
designated as the server. All other users then access the shared data files on this computer. It is DrSoft 
recommendation that you should use a dedicated server rather than peer to peer networking. A peer to peer system is 
prone to errors and corruptions due to user’s computers is designated as the server being turned off, rebooted or 
crashed. Even for the relatively simple connection of a few computers, there is a wide variety in how a windows based 
network can be setup. The method used to network Log Checker data involves sharing a directory. If you have 
implemented firewalls or security, you will need to seek advice from your computer / network administrator. 
 
To implement a network implementation of Log Checker, you will need 

·  Log Checker installation media (CD) 
·  Log Checker Activation keys  
·  Working network (can already share files and directories) 
·  Logon details for each User 
·  User Accounts must have full admin rights on the computers in order to install and register Log Checker. 

 

Step 1. Gather Information 
 
In the commands that follow, we will refer to the user’s computers that is designated as the server as MasterPC. Other 
user’s computers will be referred to as UserPC. Wherever you see these names, substitute your real computer names. 
  
You must know the names of all computers involved. To locate this information right click My Computer or Network 
Neighborhood icon (depending on the operating system), and click the Identification tab. If you are using XP, right click 
My computer and click properties then click the Computer Name tab.  You will see the computer name beside the field, 
Full Computer Name. 
  
Now, fill out the following table and store it with your Log Checker installation media and License key when we are 
finished 
 
 Actual Computer name Used by 

MasterPC   
   

  
  
  

UserPC 

  

 



�   Page 50  June 29, 2009 

 

Step 2. Install on MasterPC 
 
The MasterPC has the program and the data files. The data is shared to other users by sharing the directory on the 
network. As we are now sharing the data files, we will also need to reconfigure the Borland database Engine to perform 
network control.  
 
2.1. Logon to the MasterPC  with the user name under which you will use the program 
 
2.2. Install and register Log Checker 

2.2.A. Install Log Checker making a note of the data installation directory here 
[ ] default  = c:\LogCheckerData 
[ ] custom = ______________________________________ ____ 

2.2.B. Reboot the PC 
2.2.C. Start Log Checker and activate it 
2.2.D. make sure that Log Checker has installed and runs properly 
2.2.E. Close Log Checker 

 
2.3. Create a network share 

2.3.A. Open Windows Explorer by right clicking on the Start Button and choosing Explore 
2.3.B. Now navigate to the installation folder as entered during the install 2.2.A above 
2.3.C. Right Click on the installation (logchecker) folder 
2.3.D. When the menu pops up, choose Sharing and Security 
2.3.E. In the Networking Sharing and Security section, 

i check the square by Share This folder on the Network. 
ii Enter  logcheck as the Share Name 
iii Check allow Network users to change my files 
iv Click on Apply 
v Click on Ok 

2.3.F. A hand should now appear under the installation (logchecker) folder. 
2.3.G. Close Windows explorer 

 
2.4.  Check network share 

2.4.A.  Click on the start button and choose run 
2.4.B. enter \\MasterPC\logcheck and press enter (don’t forget to substitute your real computers name for 

MasterPC 
2.4.C. Windows explorer should open and display the contents of the installation directory. If it does not, check 

step 2.3 and 2.4 again. If it still doesn’t work, you have a network / security issue and need to talk to your 
computer / network administrator. 

2.4.D. Close windows explorer 
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2.5.  Reconfigure the BDE settings on MasterPC 
2.5.A.  Open the BDE configuration utility. (A shortcut to the BDE configuration tool is located in the LogChecker 4 

programs folder) 
2.5.B. Click on the Drivers Tab 
2.5.C. Then on Paradox. 
2.5.D. Click NET DIR, and type the path name \\MasterPC\logcheck (dont forget to use the real computer name) 

This is the location of the Pdoxusrs.net (network control file).  This path must be the same on all the computers  
2.5.E. Choose File -> Save 
2.5.F. Click on the System Tab 
2.5.G. Change the Local Share  to TRUE 
2.5.H. Choose File -> Save. 
2.5.I. Now click on the Aliases Tab 
2.5.J. Click on LC. 

Change the Path definition to \\MasterPC\logcheck  
2.5.K. Choose File -> Save 
2.5.L. Close the BDE configuration utility 

 
2.6. Remove any previous BDE network control files 

2.6.A. Open windows explorer 
2.6.B. Search all directories for PDOXUSRS.NET 
2.6.C. Delete all files that are found 
2.6.D. Search all directories for P*.LCK 
2.6.E. Delete any file named PARADOX.LCK or PDOXUSRS.LCK  

 
2.7. Test Logchecker 

2.7.A. Start LogChecker 
2.7.B. make sure that Log Checker runs properly 

If it doesn’t,  go through 2.5 and 2.6 again.  
Reboot the computer and then try log checker again  
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Step 3. Install on UserPC 
 
The UserPC only needs the program. It must also be able to connect to the MasterPC that contains the data files. We 
will also need to reconfigure the Borland database Engine to have the same settings as the MasterPC to perform 
network control. The easiest way is to install it as a stand alone then change it to networked. 
 
3.1. Logon to the UserPC with the user name under which you will use the program on that computer 
 
3.2. Install and register Log Checker 

3.2.A. Install Log Checker making note of the installation directory here 
[ ] default  = c:\logcheckerData 
[ ] custom = ______________________________________ ____ 

3.2.B. Reboot the PC 
3.2.C. Start Log Checker and enter the activation key 
3.2.D. make sure that Log Checker has installed and runs properly 
3.2.E. Close Log Checker 

 
3.3. Check network access 

3.3.A.  Click on the start button and choose run 
3.3.B. enter \\MasterPC\logcheck and press enter (don’t forget to substitute your real computers name for 

MasterPC 
3.3.C. Windows explorer should open and display the contents of the installation directory. If it does not, you 

have a network / security issue and need to talk to  your computer / network administrator.  
3.3.D. Close windows explorer 

 
3.4. Delete unneeded data files 

3.4.A. Open Windows Explorer by right clicking on the Start Button and choosing Explore 
3.4.B. Now navigate to the installation folder as entered during the install 3.2.A above 
3.4.C. Delete the data folder  
3.4.D. Select ok and close windows explorer 

 
3.5.  Reconfigure the BDE settings on UserPC 

3.5.A.  Open the BDE configuration utility. (A shortcut to the BDE configuration tool is located in the LogChecker 4 
programs folder) 

3.5.B. Click on the Drivers Tab 
3.5.C. Then on Paradox. 
3.5.D. Click NET DIR, and type the path name \\MasterPC\logcheck (dont forget to use the real computer name) 

This is the location of the Pdoxusrs.net (network control file).  This path must be the same on all the computers  
3.5.E. Choose File -> Save 
3.5.F. Click on the System Tab 
3.5.G. Change the Local Share  to TRUE 
3.5.H. Choose File -> Save. 
3.5.I. Now click on the Aliases Tab 
3.5.J. Click on LC. 

Change the Path definition to  \\MasterPC\logcheck  
3.5.K. Choose File -> Save 
3.5.L. Close the BDE configuration utility 

 
3.6. Remove any previous BDE network control files 

3.6.A. Open windows explorer 
3.6.B. Search all directories for PDOXUSRS.NET 
3.6.C. Delete all files that are found 
3.6.D. Search all directories for P*.LCK 
3.6.E. Delete any file named PARADOX.LCK or PDOXUSRS.LCK  

 
3.7.  Check that the networked Log Checker works on the UserPc 

3.7.A. On all other computers, Close Log Checker  
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3.7.B. Start Log Checker on the UserPC 
3.7.C. make sure that Log Checker runs properly 

If it doesn’t ,  go through 3.3 and 3.5 again. Rebo ot the computer and then try log checker again.,  g o 
through 3.5 again. Reboot the computer and then try  log checker again. If it does not work, you have a  
network / security issue and need to talk to your c omputer / network administrator. 

3.7.D. Start Log Checker on the MasterPC 
3.7.E. make sure that Log Checker runs properly 
3.7.F. now close Log Checker on all the computers 

 
3.8.  repeat step 3 for any other UserPCs 
3.9.  Lastly save this document with your license key and  install media 
 
3.10.  Don’t forget to do regular backups of the logchecke r data files! 

The files you need to backup are in the data folder  of the installation directory (see 2.2.A) of the 
MasterPC. If you don’t have a backup program, use t he simple one that comes with LogChecker (Click 
start, All Programs, Log Checker, Log Checker Backu p) 

 


